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EXCEL - USEFUL FUNCTIONS AND INFORMATION - BASICS

INSERT A NEW ROW 

· Place the cursor in the cell below where you want the new row to be inserted

· Open Insert on the menu bar
· Select Row to insert a new row - always in

INSERT A NEW COLUMN

As above but place the cursor in the cell to the right of where you want the new column to be inserted

TO FORMAT THE CELLS

· Highlight the area you wish to format - if you don't, nothing will
 happen!

· Open the Format menu form the menu bar

· Select cells
· Select the appropriate format from the category list (see figure below)

TO CHANGE THE NUMBER OF DECIMAL PLACES
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As above

· Select the number tab

· Select number on the left
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Using the down-arrow select the number of decimal places required

TO SHOW FORMULAE

· Open Tools from the menu bar
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Select Options 
· Select the View tab
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Click Formulas
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TO SHOW GRIDLINES

As above but check the Gridlines box

If this does not work - open the File menu

· Select Page Setup
· Select the Sheet tab
· Check Gridlines
RELATIONAL OPERATORS

=
Equal to

>
Greater than

<
Less than

>=
Greater than or equal to

<=
Less than or equal to

<>
Not equal to

BASIC CALCULATIONS

Always select = before entering a calculation to bring up the Function Wizard (Paste function) e.g.

=SUM(B4:B26) 
-
Adds up all the figures in the range B4 to B26 
     
(not case sensitive)

=B2+B3

-
Adds together cells B2 and B3

=C7-C6

-
Subtracts C6 from C7

=E72*E78

-
Multiplies E72 by E78

=H12/A4

-
Divides H12 by A4

=Average(H6:H20)
-
Finds the average for the range H6 to H20

=COUNT(F12:F29)
-
Counts the number of cells in that range

=MIN(F12:F59)
-
Finds the minimum value in that range

=MAX(F12:F59)
-
Finds the maximum value in that range

=RANDBETWEEN
-
Calculates random numbers from given values -





 e.g. =RANDBETWEEN(1,49) will give a random 



number between 1 and 49 - copy the formula to 
 



an area 6 columns wide and however many rows
  



you require and you will be given a selection of

 



random numbers between 1 and 49 - Worth a try!

PROTECTING YOUR WORKSHEET
· Highlight the cells you do not want to protect (hold down Ctrl button if cells are in different parts of the worksheet).
· Open Format on the menu bar
· Select Cells

· Click Protection tab

· Uncheck locked box

· Select Tools from the menu bar

· Select Protection 

· Protect sheet
DATA SERIES

e.g. type 1400 in cell A2, to increment the count to 1410 - highlight the cells the numbers are to go into - select Edit, Fill, Series, in columns or rows (whichever you require), linear then ok  Excel will fill in missing values

TO ENABLE AUTO COMPLETE

Select Tools, Options, Edit Tab - enable AutoComplete.

TO HIDE ROWS/COLUMNS

Click on a cell in the row or column that you wish to format. Select Format, row/column, then hide.

TO SORT DATABASE

Highlight ALL data to be sorted (including headings); click Data menu from toolbar, select sort, select the field you wish to sort by, likewise with then by, if you want to sort on more than one field. Make sure Header row is selected, click OK. 

TO SEARCH EXCEL DATABASE

Make sure cursor is in one of the database cells. Open Data menu, select Form, click criteria button, enter criteria you are searching for (can enter more than one criterion), select find next (repeatedly) all records which match the criteria will be displayed. Select criteria, clear, close when you have finished.

TO ADD A FILTER
· Open the Data menu
To add a simple filter select the following
· Filter

· Auto filter

· This will place a down-arrow on each field
· Click the down arrow in the field/column you wish to search
· e.g. in fig a. below – click the down arrow in the Co. Name field – Click Patel Industries – Patel Industries only will appear on the resulting data set

TO REMOVE THE FILTER

· Open the Data menu

Select the following

· Filter

· Show all – this will return the full data set

· Click Data 
· Remove the tick from AutoFilter by clicking onto it – this will completely remove the filter

ADVANCED FILTER

· Highlight the column headings (field names) 

· Select Copy
· Place the cursor a couple of rows below the end of the table

· Select paste
· Enter the criteria you are searching for in the appropriate column – e.g. Patel Industries in Fig. a. below – make sure you press enter or click with the mouse afterwards

· Highlight the database/table you wish to select from 

· Open the Data menu

Select the following

· Filter

· Advanced Filter

· In the Advanced Filter dialogue box select : -

· Action: Filter the list in place
· The List range is the range for the entire database (already selected)

· The Criteria Range is the range for the area that you have cut and pasted (already selected)

· Click OK 
· The resulting data set will be for the item searched for – in this case Patel Industries.

TO ADD SUBTOTALS TO YOUR EXCEL DATABASE

	Order No.
	Order Date
	Co.Ref
	Co.Name
	Value
	VAT
	Total

	14008
	12-Mar
	2245
	Goldfield Stables
	123.85
	21.67
	145.52

	14009
	12-Mar
	1289
	Marsden Products
	1652.54
	289.19
	1941.73

	14003
	11-Mar
	1289
	Marsden Products
	4456.00
	779.80
	5235.80

	14004
	10-Mar
	2413
	Patel Industries
	567.00
	99.23
	666.23

	14001
	08-Mar
	2413
	Patel Industries
	1466.00
	256.55
	1722.55

	14006
	10-Mar
	2375
	Patel Kitchens
	55.54
	9.72
	65.26

	14005
	11-Mar
	955
	Tilley Transport
	1678.00
	293.65
	1971.65

	14002
	11-Mar
	1453
	Wilson Garages
	98.76
	17.28
	116.04

	14007
	09-Mar
	1453
	Wilson Garages
	2654.00
	464.45
	3118.45

	14000
	10-Mar
	1453
	Wilson Garages
	3200.00
	560.00
	3760.00


Fig a

Sort the database on the required field (e.g. Co. Name - if you want to group together data for each company) - see step To Sort Database above.  Highlight whole database, open Data menu, select subtotals, In first field, at each change in, select required field (Co. Name), use function select sum, add subtotal to, select total, click OK. By clicking on the number buttons on the left hand side of the screen you can select criteria you wish to see displayed, this can also be done by clicking the + and - signs on the left hand side (very clever!)  The sorted database should appear as below - each company has it's own sub-total. To remove subtotals, select the data menu, subtotals, remove all.

	Order No.
	Order Date
	Co.Ref
	Co.Name
	Value
	VAT
	Total

	14008
	12-Mar
	2245
	Goldfield Stables
	123.85
	21.67
	145.52

	
	
	
	Goldfield Stables Total
	
	
	145.52

	14009
	12-Mar
	1289
	Marsden Products
	1652.54
	289.19
	1941.73

	14003
	11-Mar
	1289
	Marsden Products
	4456.00
	779.80
	5235.80

	
	
	
	Marsden Products Total
	
	
	7177.53

	14004
	10-Mar
	2413
	Patel Industries
	567.00
	99.23
	666.23

	14001
	08-Mar
	2413
	Patel Industries
	1466.00
	256.55
	1722.55

	
	
	
	Patel Industries Total
	
	
	2388.78

	14006
	10-Mar
	2375
	Patel Kitchens
	55.54
	9.72
	65.26

	
	
	
	Patel Kitchens Total
	
	
	65.26

	14005
	11-Mar
	955
	Tilley Transport
	1678.00
	293.65
	1971.65

	
	
	
	Tilley Transport Total
	
	
	1971.65

	14002
	11-Mar
	1453
	Wilson Garages
	98.76
	17.28
	116.04

	14007
	09-Mar
	1453
	Wilson Garages
	2654.00
	464.45
	3118.45

	14000
	10-Mar
	1453
	Wilson Garages
	3200.00
	560.00
	3760.00

	
	
	
	Wilson Garages Total
	
	
	6994.49

	
	
	
	Grand Total
	
	
	18743.24


Fig b

VLOOKUP

Format - =VLOOKUP(x,range,index)

Where :-

· x is the value that you want to look up; it can be entered as text, a number of a cell reference

· range is the range of cells forming the table

· index tells you which column or row to look in

For the LOOKUP function to work the first column of the lookup table must consist of entries that are used to look up items of data in immediately adjacent columns. These entries must be unique and in ascending order.
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Fig 1

=VLOOKUP(B4,D7:F11,2)

Look up B4 in range D7:F11 (range containing the data) in column 2 - the answer in this case (fig 1) is 10%.

The formula means 'look up the value in cell B4, from the table in cell range D7 to F11, in the second column of the table'. The lookup function searches the first column of compare values - column D - until it reaches a number equal to or higher than 600 (cell D9). It then goes back a row if it is higher (to cell D8), then goes to the second column (E) and looks up the discount of 10% (in cell E8). For this reason the values in the first column of the lookup table - column D - must be in ascending sequence.

NESTED IF STATEMENT

=IF(D7=0,"5%",IF(D7=500,"10%",IF(D7=1000,"15%",IF(D7=5000,"20%",IF(D7=

10000,"25%")))))

What this statement is saying is : -

If the value of D7 is 500 then award a bonus of 10% ELSE IF

the value of D7 is 1000 then award a bonus of 15%   ELSE IF

the value of D7 is 5000 then award a bonus of 20%   ELSE IF

the value of D7 is 10000 then award a bonus of 25% 
The comma represents the ELSE part of the statement - it is very important to get the brackets (parentheses) correct - you always need the same amount of closing brackets as opening brackets.

TO CALCULATE HOW MUCH INTEREST YOU CAN ACCRUE

e.g. you are going to save £1,000 per year for 5 years at 10% interest rate. In any cell on a workbook type in the formula =FV(10%,5,-1000)  press enter - hey presto, the answer appears (£6,105.10).

TO CALCULATE STRAIGHT LINE DEPRECIATION

e.g. you have bought a PC for £1,000 and estimate that in 4 years it will be worth £300.  Select a blank cell on the worksheet.  Open Insert menu and select function, select Financial from the function category box, and SLN  from the function name box. click OK.  Enter the arguments into the paste function dialogue box, In cost row type 1000, in salvage box type 300, in Life box type 4, click OK answer appears in the cell you're in on the worksheet.

Display or hide zero values

1. On the Tools menu, click Options then click the View tab.

2. To display zero (0) values in cells, select the zero values check box.

3. To display zero values as blank cells, clear the check box.

To create a named range table on the spreadsheet.

1. Choose Insert/name/paste.
2. In the Paste List dialogue box choose Paste List.
To create a macro

1. Choose Tools/Macro/Record New Macro
2. Give the macro a name in the Record Macro dialogue box (do not use spaces)


3. Create a shortcut key if you wish by adding a letter in the shortcut key box

4. Click OK

5. Complete the actions you wish to record

6. Click Tools/Macro/Stop recording or click the Stop Recording dialogue box which appears on the screen.

Create the following macro: -

1. Carry out 1 and 2 above.

2. Name the macro print_sheet

3. Type a letter p in the shortcut key box

4. Click OK

5. Carry out the actions to actually print the sheet you are working on.

6. Stop recording.

7. Press Ctrlp - hopefully the sheet will automatically print out.

Creating a menu screen

Use mock assignment one

1. If you cannot see the Forms toolbar on screen click View/Toolbars/Forms
2. Insert a new worksheet if necessary

3. Highlight the sheet (viewable on screen)

4. Change the background colour

5. Type Main Menu at the top - change large font/size/style

6. Rename the sheet MainMen

HINT:- DO NOT RENAME SHEETS AFTER YOU HAVE RECORDED ANY MACROS - THEY WILL NOT WORK BECAUSE EXCEL NO LONGER RECOGNISES THE NAME OF THE SHEET.

Leave it like that for the time being.

A   Record a macro whilst you are on the pie chart which will return to the main menu.

1. Click Tools/macro/record new macro

2. Name the macro ReturnToMainmen

3. Whilst you are on the pie chart click onto the MainMen tab - this will take you back to the main menu
4.  Click Tools/macro/stop recording

B You can now place a navigational button on the pie chart screen, which will run this macro - this is the same as in Access.

1. Click the Button control on the form menu bar

2. Draw a button on the pie chart screen


3. Select the Macro you wish to run - in this case it is ReturnToMainMen

4. Click OK

To rename the button

1. Right click onto the button

2. Select Edit Text

3. Give the button a suitable name

4. Test the button by clicking it!

You can now repeat A and B above but in reverse.

Create a macro whilst you are on the main menu to open the pie chart.

Create a button on the Main Menu to run that Macro. 

Hint:  If you want to move the button at any time

1. Right Click onto it
2. Select Format Control

3. Select the Properties Tab

4.  Select Move and size with cell
� EMBED Excel.Sheet.8  ���








1
13
Sheila Jolley - Excel tips


_1041943092.xls
Sheet1

								Order Discount look-up

		Cash Order

		Order Value:		600

		Discount		10%

		Net Value						Order Value		Cash		Credit

								0		5%		0%

		Credit order						500		10%		5%

		Order Value:						1000		15%		10%

		Discount						5000		20%		15%

		Net Value						10000		25%		20%





Sheet2

		





Sheet3

		






